BankID is currently experiencing partial outage
Incident Report for Idfy
Resolved
This incident has been resolved.
Posted 21 days ago. Nov 26, 2018 - 13:00 CET
Identified
BankID is currently experiencing partial outage.
Users affected: Approx. 25%
Posted 21 days ago. Nov 26, 2018 - 12:37 CET
This incident affected: E-ID providers (BankID (no)).