Our hosting provider is experiencing network issues
Incident Report for Idfy
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 05, 2019 - 10:06 CET
Identified
Our hosting provider is experiencing Netoworks issues, that affects our Signature service and our PAdES creation service.
Posted 7 months ago. Feb 05, 2019 - 08:40 CET
This incident affected: Signature (Signature services) and Additional services (PAdES).